What’s Vulnerable › Vulnerabilities
CVE-2023-7332: PocketMine-MP < 4.18.1 Improper Validation of Dropped Item Count Allows Remote Server Crash
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-31 · updated 2026-10-28
- Weakness: CWE-1284
Description
PocketMine-MP versions prior to 4.18.1 contain an improper input validation vulnerability in inventory transaction handling. A remote attacker with a valid player session can request that the server drop more items than are available in the player's hotbar, triggering a server crash and resulting in denial of service.
Affected products
- pmmp PocketMine-MP: before 4.18.1 — fixed in 4.18.1
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.18.1. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/blob/4.18.1/changelogs/4.18.md
- https://github.com/pmmp/PocketMine-MP/commit/5897476
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-h87r-f4vc-mchv
- https://www.vulncheck.com/advisories/pocketmine-mp-improper-validation-of-dropped-item-count-allows-remote-server-crash
Get alerted when CVE-2023-7332 or the next vulnerability affects your stack