What’s Vulnerable › Vulnerabilities
CVE-2024-0007: PAN-OS: Stored Cross-Site Scripting (XSS) Vulnerability in the Panorama Web Interface
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS software enables a malicious authenticated read-write administrator to store a JavaScript payload using the web interface on Panorama appliances. This enables the impersonation of another authenticated administrator.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.24; from 9.0.0 before 9.0.17; from 9.1.0 before 9.1.16; from 10.0.0 before 10.0.11; from 10.1.0 before 10.1.6; 8.1.24 — fixed in 8.1.24, 9.0.17, 9.1.16, 10.0.11, 10.1.6
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.24-h1; from 8.1 before 8.1.25; from 9.0 before 9.0.17; from 9.1 before 9.1.16; from 10.0 before 10.0.11; from 10.1 before 10.1.6 — fixed in 8.1.24-h1, 8.1.25, 9.0.17, 9.1.16, 10.0.11, 10.1.6
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.24, 9.0.17, 9.1.16, 10.0.11; Palo Alto Networks PAN-OS 8.1.24-h1, 8.1.25, 9.0.17, 9.1.16. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2024-0007
- https://security.paloaltonetworks.com/CVE-2024-0007
Get alerted when CVE-2024-0007 or the next vulnerability affects your stack