What’s Vulnerable › Vulnerabilities
CVE-2024-0010: PAN-OS: Reflected Cross-Site Scripting (XSS) Vulnerability in GlobalProtect Portal
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability in the GlobalProtect portal feature of Palo Alto Networks PAN-OS software enables execution of malicious JavaScript (in the context of a user’s browser) if a user clicks on a malicious link, allowing phishing attacks that could lead to credential theft.
Affected products
- Palo Alto Networks PAN-OS: from 10.1.0 before 10.1.11; from 9.1.0 before 9.1.17; from 9.0.0 before 9.0.17; 10.1.11, 9.0.17, 9.0.17-h1, 9.0.17-h2, 9.0.17-h3 — fixed in 10.1.11, 9.0.17, 9.1.17
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.1.11, 9.0.17, 9.1.17. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2024-0010
- https://security.paloaltonetworks.com/CVE-2024-0010
Get alerted when CVE-2024-0010 or the next vulnerability affects your stack