What’s Vulnerable › Vulnerabilities
CVE-2024-0011: PAN-OS: Reflected Cross-Site Scripting (XSS) Vulnerability in Captive Portal Authentication
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability in the Captive Portal feature of Palo Alto Networks PAN-OS software enables execution of malicious JavaScript (in the context of an authenticated Captive Portal user’s browser) if a user clicks on a malicious link, allowing phishing attacks that could lead to credential theft.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.24; from 9.0.0 before 9.0.17; from 9.1.0 before 9.1.13; from 10.0.0 before 10.0.11; from 10.1.0 before 10.1.3 — fixed in 8.1.24, 9.0.17, 9.1.13, 10.0.11, 10.1.3
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.24; from 9.0 before 9.0.17; from 9.1 before 9.1.13; from 10.0 before 10.0.11; from 10.1 before 10.1.3 — fixed in 8.1.24, 9.0.17, 9.1.13, 10.0.11, 10.1.3
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.24, 9.0.17, 9.1.13, 10.0.11; Palo Alto Networks PAN-OS 8.1.24, 9.0.17, 9.1.13, 10.0.11. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2024-0011
- https://security.paloaltonetworks.com/CVE-2024-0011
Get alerted when CVE-2024-0011 or the next vulnerability affects your stack