What’s Vulnerable › Vulnerabilities
CVE-2024-0161
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-20
Description
Dell PowerEdge Server BIOS and Dell Precision Rack BIOS contain an Improper SMM communication buffer verification vulnerability. A local low privileged attacker could potentially exploit this vulnerability leading to arbitrary writes to SMRAM.
Affected products
- Dell Dss 8440 Firmware: before 2.21.0 — fixed in 2.21.0
- Dell Emc Storage Nx3240 Firmware: before 2.21.2 — fixed in 2.21.2
- Dell Emc Storage Nx3340 Firmware: before 2.21.2 — fixed in 2.21.2
- Dell Emc Xc Core 6420 Firmware: before 2.21.0 — fixed in 2.21.0
- Dell Emc Xc Core Xc450 Firmware: before 1.13.2 — fixed in 1.13.2
- Dell Emc Xc Core Xc640 Firmware: before 2.21.2 — fixed in 2.21.2
- Dell Emc Xc Core Xc650 Firmware: before 1.13.2 — fixed in 1.13.2
- Dell Emc Xc Core Xc6520 Firmware: before 1.13.2 — fixed in 1.13.2
- Dell Emc Xc Core Xc740Xd2 Firmware: before 2.21.1 — fixed in 2.21.1
- Dell Emc Xc Core Xc740Xd Firmware: before 2.21.2 — fixed in 2.21.2
- Dell Emc Xc Core Xc750 Firmware: before 1.13.2 — fixed in 1.13.2
- Dell Emc Xc Core Xc750Xa Firmware: before 1.13.2 — fixed in 1.13.2
- Dell Emc Xc Core Xc940 Firmware: before 2.21.2 — fixed in 2.21.2
- Dell Emc Xc Core Xcxr2 Firmware: before 2.21.1 — fixed in 2.21.1
- Dell Poweredge C4130 Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge C4140 Firmware: before 2.21.1 — fixed in 2.21.1
- Dell Poweredge C6320 Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge C6420 Firmware: before 2.21.0 — fixed in 2.21.0
- Dell Poweredge C6520 Firmware: before 1.13.2 — fixed in 1.13.2
- Dell Poweredge Fc430 Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge Fc630 Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge Fc640 Firmware: before 2.21.0 — fixed in 2.21.0
- Dell Poweredge Fc830 Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge M630 (Pe Vrtx) Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge M630 Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge M640 (Pe Vrtx) Firmware: before 2.21.0 — fixed in 2.21.0
- Dell Poweredge M640 Firmware: before 2.21.0 — fixed in 2.21.0
- Dell Poweredge M830 (Pe Vrtx) Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge M830 Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Poweredge Mx740C Firmware: before 2.21.0 — fixed in 2.21.0
How to fix
Upgrade to a fixed version: Dell Dss 8440 Firmware 2.21.0; Dell Emc Storage Nx3240 Firmware 2.21.2; Dell Emc Storage Nx3340 Firmware 2.21.2; Dell Emc Xc Core 6420 Firmware 2.21.0; Dell Emc Xc Core Xc450 Firmware 1.13.2; Dell Emc Xc Core Xc640 Firmware 2.21.2; Dell Emc Xc Core Xc650 Firmware 1.13.2; Dell Emc Xc Core Xc6520 Firmware 1.13.2; Dell Emc Xc Core Xc740Xd2 Firmware 2.21.1; Dell Emc Xc Core Xc740Xd Firmware 2.21.2; Dell Emc Xc Core Xc750 Firmware 1.13.2; Dell Emc Xc Core Xc750Xa Firmware 1.13.2. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000222979/dsa-2024-006-security-update-for-dell-poweredge-server-bios-for-an-improper-smm-communication-buffer-verification-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000222979/dsa-2024-006-security-update-for-dell-poweredge-server-bios-for-an-improper-smm-communication-buffer-verification-vulnerability
Get alerted when CVE-2024-0161 or the next vulnerability affects your stack