What’s Vulnerable › Vulnerabilities
CVE-2024-0172
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-03 · updated 2026-06-17
- Weakness: CWE-269
Description
Dell PowerEdge Server BIOS and Dell Precision Rack BIOS contain an improper privilege management security vulnerability. An unauthenticated local attacker could potentially exploit this vulnerability, leading to privilege escalation.
Affected products
- Dell Dss 8440 Firmware: before 2.19.0 — fixed in 2.19.0
- Dell Emc Storage Nx3240 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Emc Storage Nx3340 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Emc Xc Core 6420 System Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Emc Xc Core Xc450 Firmware: before 1.11.2 — fixed in 1.11.2
- Dell Emc Xc Core Xc640 System Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Emc Xc Core Xc650 Firmware: before 1.11.2 — fixed in 1.11.2
- Dell Emc Xc Core Xc6520 Firmware: before 1.11.2 — fixed in 1.11.2
- Dell Emc Xc Core Xc740Xd2 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Emc Xc Core Xc740Xd System Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Emc Xc Core Xc750 Firmware: before 1.11.2 — fixed in 1.11.2
- Dell Emc Xc Core Xc750Xa Firmware: before 1.11.2 — fixed in 1.11.2
- Dell Emc Xc Core Xc7525 Firmware: before 2.12.4 — fixed in 2.12.4
- Dell Emc Xc Core Xc940 System Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Emc Xc Core Xcxr2 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Nx440 Firmware: before 2.14.1 — fixed in 2.14.1
- Dell Poweredge C4140 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Poweredge C6420 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Poweredge C6520 Firmware: before 1.11.2 — fixed in 1.11.2
- Dell Poweredge C6525 Firmware: before 2.12.4 — fixed in 2.12.4
- Dell Poweredge C6620 Firmware: before 1.5.6 — fixed in 1.5.6
- Dell Poweredge Fc640 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Poweredge Hs5610 Firmware: before 1.5.6 — fixed in 1.5.6
- Dell Poweredge Hs5620 Firmware: before 1.5.6 — fixed in 1.5.6
- Dell Poweredge M640 (Pe Vrtx) Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Poweredge M640 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Poweredge Mx740C Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Poweredge Mx750C Firmware: before 1.11.2 — fixed in 1.11.2
- Dell Poweredge Mx760C Firmware: before 1.5.6 — fixed in 1.5.6
- Dell Poweredge Mx840C Firmware: before 2.19.1 — fixed in 2.19.1
How to fix
Upgrade to a fixed version: Dell Dss 8440 Firmware 2.19.0; Dell Emc Storage Nx3240 Firmware 2.19.1; Dell Emc Storage Nx3340 Firmware 2.19.1; Dell Emc Xc Core 6420 System Firmware 2.19.1; Dell Emc Xc Core Xc450 Firmware 1.11.2; Dell Emc Xc Core Xc640 System Firmware 2.19.1; Dell Emc Xc Core Xc650 Firmware 1.11.2; Dell Emc Xc Core Xc6520 Firmware 1.11.2; Dell Emc Xc Core Xc740Xd2 Firmware 2.19.1; Dell Emc Xc Core Xc740Xd System Firmware 2.19.1; Dell Emc Xc Core Xc750 Firmware 1.11.2; Dell Emc Xc Core Xc750Xa Firmware 1.11.2. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000223727/dsa-2024-035-security-update-for-dell-poweredge-server-bios-for-an-improper-privilege-management-security-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000223727/dsa-2024-035-security-update-for-dell-poweredge-server-bios-for-an-improper-privilege-management-security-vulnerability
Get alerted when CVE-2024-0172 or the next vulnerability affects your stack