What’s Vulnerable › Vulnerabilities
CVE-2024-0187: Community by PeepSo < 6.3.1.2 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Community by PeepSo WordPress plugin before 6.3.1.2 does not sanitise and escape various parameters and generated URLs before outputting them back attributes, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles: before 6.3.1.2 — fixed in 6.3.1.2
How to fix
Upgrade to a fixed version: PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles 6.3.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b4600411-bee1-4cc8-aee9-0a613ac9b55b/
- https://wpscan.com/vulnerability/b4600411-bee1-4cc8-aee9-0a613ac9b55b/
Get alerted when CVE-2024-0187 or the next vulnerability affects your stack