What’s Vulnerable › Vulnerabilities

CVE-2024-0199: Incorrect Authorization in GitLab

Description

An authorization bypass vulnerability was discovered in GitLab affecting versions 11.3 prior to 16.7.7, 16.7.6 prior to 16.8.4, and 16.8.3 prior to 16.9.2. An attacker could bypass CODEOWNERS by utilizing a crafted payload in an old feature branch to perform malicious actions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.7.7, 16.8.4, 16.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-0199 or the next vulnerability affects your stack