What’s Vulnerable › Vulnerabilities

CVE-2024-0200: Unsafe Reflection in Github Enterprise Server leading to Command Injection

Description

An unsafe reflection vulnerability was identified in GitHub Enterprise Server that could lead to reflection injection. This vulnerability could lead to the execution of user-controlled methods and remote code execution. To exploit this bug, an actor would need to be logged into an account on the GHES instance with the organization owner role. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.8.13, 3.9.8, 3.10.5, and 3.11.3. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.10.5, 3.11.3, 3.8.13, 3.9.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-0200 or the next vulnerability affects your stack