What’s Vulnerable › Vulnerabilities
CVE-2024-0213
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-09 · updated 2026-06-17
- Weakness: CWE-120
Description
A buffer overflow vulnerability in TA for Linux and TA for MacOS prior to 5.8.1 allows a local user to gain elevated permissions, or cause a Denial of Service (DoS), through exploiting a memory corruption issue in the TA service, which runs as root. This may also result in the disabling of event reporting to ePO, caused by failure to validate input from the file correctly.
Affected products
- Trellix Agent: before 5.8.1 — fixed in 5.8.1
How to fix
Upgrade to a fixed version: Trellix Agent 5.8.1. Check the vendor advisory for mitigations.
References
- https://kcm.trellix.com/corporate/index?page=content&id=SB10416
- https://kcm.trellix.com/corporate/index?page=content&id=SB10416
Get alerted when CVE-2024-0213 or the next vulnerability affects your stack