What’s Vulnerable › Vulnerabilities
CVE-2024-0239: Contact Form 7 Connector < 1.2.3 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form 7 Connector WordPress plugin before 1.2.3 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against administrators.
Affected products
- ARI Soft Contact Form 7 Connector: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: ARI Soft Contact Form 7 Connector 1.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b9a4a3e3-7cdd-4354-8541-4219bd41c854/
- https://wpscan.com/vulnerability/b9a4a3e3-7cdd-4354-8541-4219bd41c854/
Get alerted when CVE-2024-0239 or the next vulnerability affects your stack