What’s Vulnerable › Vulnerabilities
CVE-2024-0241: encoded_id-rails Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-04 · updated 2026-07-14
- Weakness: CWE-400
Description
encoded_id-rails versions before 1.0.0.beta2 are affected by an uncontrolled resource consumption vulnerability. A remote and unauthenticated attacker might cause a denial of service condition by sending an HTTP request with an extremely long "id" parameter.
Affected products
- Diaconou Encodedid::Rails: before 1.0.0; 1.0.0, 1.0.0-beta1 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Diaconou Encodedid::Rails 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-3px7-jm2p-6h2c
- https://github.com/stevegeek/encoded_id-rails/commit/afa495a77b8a21ad582611f9cdc2081dc4018b91
- https://github.com/stevegeek/encoded_id-rails/security/advisories/GHSA-3px7-jm2p-6h2c
- https://vulncheck.com/advisories/vc-advisory-GHSA-3px7-jm2p-6h2c
- https://github.com/advisories/GHSA-3px7-jm2p-6h2c
- https://github.com/stevegeek/encoded_id-rails/commit/afa495a77b8a21ad582611f9cdc2081dc4018b91
- https://github.com/stevegeek/encoded_id-rails/security/advisories/GHSA-3px7-jm2p-6h2c
- https://vulncheck.com/advisories/vc-advisory-GHSA-3px7-jm2p-6h2c
Get alerted when CVE-2024-0241 or the next vulnerability affects your stack