What’s Vulnerable › Vulnerabilities
CVE-2024-0242: Unauthorized access to settings in Qolsys IQ Panel 4 and IQ4 Hub
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-08 · updated 2026-06-17
- Weakness: CWE-200
Description
Under certain circumstances IQ Panel4 and IQ4 Hub panel software prior to version 4.4.2 could allow unauthorized access to settings.
Affected products
- Johnsoncontrols Qolsys Iq4 Hub Firmware: before 4.4.2 — fixed in 4.4.2
- Johnsoncontrols Qolsys Iq Panel 4 Firmware: before 4.4.2 — fixed in 4.4.2
How to fix
Upgrade to a fixed version: Johnsoncontrols Qolsys Iq4 Hub Firmware 4.4.2; Johnsoncontrols Qolsys Iq Panel 4 Firmware 4.4.2. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-039-01
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-039-01
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
Get alerted when CVE-2024-0242 or the next vulnerability affects your stack