What’s Vulnerable › Vulnerabilities
CVE-2024-0321: Stack-based Buffer Overflow in gpac/gpac
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-08 · updated 2026-06-17
- Weakness: CWE-121
Description
Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV.
Affected products
- GPAC: before 2.3.0-dev — fixed in 2.3.0-dev
How to fix
Upgrade to a fixed version: GPAC 2.3.0-dev. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/d0ced41651b279bb054eb6390751e2d4eb84819a
- https://huntr.com/bounties/4c027b94-8e9c-4c31-a169-893b25047769
- https://github.com/gpac/gpac/commit/d0ced41651b279bb054eb6390751e2d4eb84819a
- https://huntr.com/bounties/4c027b94-8e9c-4c31-a169-893b25047769
Get alerted when CVE-2024-0321 or the next vulnerability affects your stack