What’s Vulnerable › Vulnerabilities
CVE-2024-0368: Hustle <= 7.8.3 - Sensitive Information Exposure via Exposed Hubspot API Keys
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-522
Description
The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 7.8.3 via hardcoded API Keys. This makes it possible for unauthenticated attackers to extract sensitive data including PII.
Affected products
- wpmudev Hustle – Email Marketing, Lead Generation, Optins, Popups: before 7.8.4 — fixed in 7.8.4
How to fix
Upgrade to a fixed version: wpmudev Hustle – Email Marketing, Lead Generation, Optins, Popups 7.8.4. Check the vendor advisory for mitigations.
References
- https://developers.hubspot.com/docs/api/webhooks#manage-settings-via-api
- https://developers.hubspot.com/docs/api/webhooks#scopes
- https://plugins.trac.wordpress.org/browser/wordpress-popup/trunk/inc/providers/hubspot/hustle-hubspot-api.php#L13
- https://plugins.trac.wordpress.org/changeset/3047775/wordpress-popup/trunk/inc/providers/hubspot/hustle-hubspot-api.php?old=3025070&old_path=wordpress-popup/tags/7.8.3/inc/providers/hubspot/hustle-hubspot-api.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e6d40b41-540d-476d-afde-970845543933?source=cve
- https://developers.hubspot.com/docs/api/webhooks#manage-settings-via-api
- https://developers.hubspot.com/docs/api/webhooks#scopes
- https://plugins.trac.wordpress.org/browser/wordpress-popup/trunk/inc/providers/hubspot/hustle-hubspot-api.php#L13
- https://plugins.trac.wordpress.org/changeset/3047775/wordpress-popup/trunk/inc/providers/hubspot/hustle-hubspot-api.php?old=3025070&old_path=wordpress-popup/tags/7.8.3/inc/providers/hubspot/hustle-hubspot-api.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e6d40b41-540d-476d-afde-970845543933?source=cve
Get alerted when CVE-2024-0368 or the next vulnerability affects your stack