What’s Vulnerable › Vulnerabilities
CVE-2024-0410: Improper Enforcement of Behavioral Workflow in GitLab
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-22 · updated 2026-06-17
- Weakness: CWE-841
Description
An authorization bypass vulnerability was discovered in GitLab affecting versions 15.1 prior to 16.7.6, 16.8 prior to 16.8.3, and 16.9 prior to 16.9.1. A developer could bypass CODEOWNERS approvals by creating a merge conflict.
Affected products
- GitLab: from 15.1.0 before 16.7.6; from 16.8.0 before 16.8.3; 16.9.0 — fixed in 16.7.6, 16.8.3
How to fix
Upgrade to a fixed version: GitLab 16.7.6, 16.8.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/437988
- https://hackerone.com/reports/2296778
- https://gitlab.com/gitlab-org/gitlab/-/issues/437988
- https://hackerone.com/reports/2296778
Get alerted when CVE-2024-0410 or the next vulnerability affects your stack