What’s Vulnerable › Vulnerabilities
CVE-2024-0420: MapPress Maps for WordPress < 2.88.15 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The MapPress Maps for WordPress plugin before 2.88.15 does not sanitize and escape the map title when outputting it back in the admin dashboard, allowing Contributors and above roles to perform Stored Cross-Site Scripting attacks
Affected products
- Mappresspro Mappress Maps For Wordpress: before 2.88.15 — fixed in 2.88.15
How to fix
Upgrade to a fixed version: Mappresspro Mappress Maps For Wordpress 2.88.15. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b6187ef8-70f4-4911-abd7-42bf6b7e54b7/
- https://wpscan.com/vulnerability/b6187ef8-70f4-4911-abd7-42bf6b7e54b7/
Get alerted when CVE-2024-0420 or the next vulnerability affects your stack