What’s Vulnerable › Vulnerabilities
CVE-2024-0447: ArtiBot Free Chat Bot for WordPress WebSites <= 1.1.6 - Missing Authorization to Settings Update
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-862
Description
The ArtiBot Free Chat Bot for WordPress WebSites plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the artibot_update function in all versions up to, and including, 1.1.6. This makes it possible for authenticated attackers, with subscriber-level access and above, to update plugin settings.
Affected products
- ArtiBot Free Chat Bot for WebSites: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: ArtiBot Free Chat Bot for WebSites 1.1.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/artibot/trunk/artibot.php#L60
- https://plugins.trac.wordpress.org/changeset/3098820/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/848f36de-c62a-45ee-b259-46dab73e4439?source=cve
- https://plugins.trac.wordpress.org/browser/artibot/trunk/artibot.php#L60
- https://www.wordfence.com/threat-intel/vulnerabilities/id/848f36de-c62a-45ee-b259-46dab73e4439?source=cve
Get alerted when CVE-2024-0447 or the next vulnerability affects your stack