What’s Vulnerable › Vulnerabilities
CVE-2024-0449: ArtiBot Free Chat Bot for WordPress WebSites <= 1.1.6 - Authenticated (Admin+) Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The ArtiBot Free Chat Bot for WordPress WebSites plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.1.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- ArtiBot Free Chat Bot for WebSites: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: ArtiBot Free Chat Bot for WebSites 1.1.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3098820/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/450d0748-93d6-448a-97a2-06fc2f8065b3?source=cve
- https://plugins.trac.wordpress.org/browser/artibot/trunk/artibot.php#L52
- https://www.wordfence.com/threat-intel/vulnerabilities/id/450d0748-93d6-448a-97a2-06fc2f8065b3?source=cve
Get alerted when CVE-2024-0449 or the next vulnerability affects your stack