What’s Vulnerable › Vulnerabilities
CVE-2024-0450: Quoted zip-bomb protection for zipfile
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-19 · updated 2026-06-17
- Weakness: CWE-405
Description
An issue was found in the CPython `zipfile` module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The zipfile module is vulnerable to “quoted-overlap” zip-bombs which exploit the zip format to create a zip-bomb with a high compression ratio. The fixed versions of CPython makes the zipfile module reject zip archives which overlap entries in the archive.
Affected products
- Python Cpython: before 3.8.18; 3.9.18, 3.10.13, 3.11.7, 3.12.1 — fixed in 3.8.18
How to fix
Upgrade to a fixed version: Python Cpython 3.8.18. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/20/5
- https://github.com/python/cpython/commit/30fe5d853b56138dbec62432d370a1f99409fc85
- https://github.com/python/cpython/commit/66363b9a7b9fe7c99eba3a185b74c5fdbf842eba
- https://github.com/python/cpython/commit/70497218351ba44bffc8b571201ecb5652d84675
- https://github.com/python/cpython/commit/a2c59992e9e8d35baba9695eb186ad6c6ff85c51
- https://github.com/python/cpython/commit/a956e510f6336d5ae111ba429a61c3ade30a7549
- https://github.com/python/cpython/commit/d05bac0b74153beb541b88b4fca33bf053990183
- https://github.com/python/cpython/commit/fa181fcf2156f703347b03a3b1966ce47be8ab3b
- https://github.com/python/cpython/issues/109858
- https://lists.debian.org/debian-lts-announce/2024/03/msg00024.html
- https://lists.debian.org/debian-lts-announce/2024/03/msg00025.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T3IGRX54M7RNCQOXVQO5KQKTGWCOABIM/
Get alerted when CVE-2024-0450 or the next vulnerability affects your stack