What’s Vulnerable › Vulnerabilities

CVE-2024-0456: Direct Request ('Forced Browsing') in GitLab

Description

An authorization vulnerability exists in GitLab versions 14.0 prior to 16.6.6, 16.7 prior to 16.7.4, and 16.8 prior to 16.8.1. An unauthorized attacker is able to assign arbitrary users to MRs that they created within the project

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.6.6, 16.7.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-0456 or the next vulnerability affects your stack