What’s Vulnerable › Vulnerabilities
CVE-2024-0507: Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 65.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-20
Description
An attacker with access to a Management Console user account with the editor role could escalate privileges through a command injection vulnerability in the Management Console. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in versions 3.11.3, 3.10.5, 3.9.8, and 3.8.13 This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: before 3.8.13; from 3.9.0 before 3.9.8; from 3.10.0 before 3.10.5; from 3.11.0 before 3.11.3 — fixed in 3.10.5, 3.11.3, 3.8.13, 3.9.8
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.10.5, 3.11.3, 3.8.13, 3.9.8. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.5
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.3
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.13
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.8
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.5
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.3
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.13
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.8
Get alerted when CVE-2024-0507 or the next vulnerability affects your stack