What’s Vulnerable › Vulnerabilities
CVE-2024-0559: Enhanced Text Widget < 1.6.6 - Admin+ Stored XSS
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Enhanced Text Widget WordPress plugin before 1.6.6 does not validate and escape some of its Widget options before outputting them back in attributes, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Enhanced Text Widget: before 1.6.6 — fixed in 1.6.6
How to fix
Upgrade to a fixed version: Enhanced Text Widget 1.6.6 . Check the vendor advisory for mitigations.
References
- https://research.cleantalk.org/cve-2024-0559/
- https://wpscan.com/vulnerability/b257daf2-9540-4a0f-a560-54b47d2b913f/
- https://research.cleantalk.org/cve-2024-0559/
- https://wpscan.com/vulnerability/b257daf2-9540-4a0f-a560-54b47d2b913f/
Get alerted when CVE-2024-0559 or the next vulnerability affects your stack