What’s Vulnerable › Vulnerabilities
CVE-2024-0593: Simple Job Board <= 2.10.8 - Missing Authorization to Unauthenticated Information Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-21 · updated 2026-06-17
- Weakness: CWE-862
Description
The Simple Job Board plugin for WordPress is vulnerable to unauthorized access of data| due to insufficient authorization checking on the fetch_quick_job() function in all versions up to, and including, 2.10.8. This makes it possible for unauthenticated attackers to fetch arbitrary posts, which can be password protected or private and contain sensitive information.
Affected products
- Simple Job Board: before 2.11.0 — fixed in 2.11.0
How to fix
Upgrade to a fixed version: Simple Job Board 2.11.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3038476/simple-job-board/trunk/includes/class-simple-job-board-ajax.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0a28a161-3dbc-4ef0-a2ce-4c102cf3cbb0?source=cve
- https://plugins.trac.wordpress.org/changeset/3038476/simple-job-board/trunk/includes/class-simple-job-board-ajax.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0a28a161-3dbc-4ef0-a2ce-4c102cf3cbb0?source=cve
Get alerted when CVE-2024-0593 or the next vulnerability affects your stack