What’s Vulnerable › Vulnerabilities
CVE-2024-0595: Awesome Support – WordPress HelpDesk & Support Plugin <= 6.1.7 - Missing Authorization via wpas_get_users()
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-10 · updated 2026-06-17
- Weakness: CWE-862
Description
The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the wpas_get_users() function hooked via AJAX in all versions up to, and including, 6.1.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to retrieve user data such as emails. CVE-2024-35741 is likely a duplicate of this issue.
Affected products
- awesomesupport Awesome Support – WordPress HelpDesk & Support Plugin: before 6.1.8 — fixed in 6.1.8
How to fix
Upgrade to a fixed version: awesomesupport Awesome Support – WordPress HelpDesk & Support Plugin 6.1.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/awesome-support/trunk/includes/functions-user.php#L765
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3033134%40awesome-support&new=3033134%40awesome-support&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bfb77432-e58d-466e-a366-8b8d7f1b6982?source=cve
- https://plugins.trac.wordpress.org/browser/awesome-support/trunk/includes/functions-user.php#L765
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3033134%40awesome-support&new=3033134%40awesome-support&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bfb77432-e58d-466e-a366-8b8d7f1b6982?source=cve
Get alerted when CVE-2024-0595 or the next vulnerability affects your stack