What’s Vulnerable › Vulnerabilities
CVE-2024-0611: Master Slider – Responsive Touch Slider <= 3.9.9 - Authenticated(Editor+) Stored Cross-Site Scripting via slider callback
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Master Slider – Responsive Touch Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the slides callback functionality in all versions up to, and including, 3.9.9. This makes it possible for authenticated attackers, with editor-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- averta Master Slider – Responsive Touch Slider: before 3.9.10 — fixed in 3.9.10
How to fix
Upgrade to a fixed version: averta Master Slider – Responsive Touch Slider 3.9.10. Check the vendor advisory for mitigations.
References
- https://advisory.abay.sh/cve-2024-0611
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3084860%40master-slider&new=3084860%40master-slider&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ac6e587c-59b2-4f93-ab88-5e548b52db45?source=cve
- https://advisory.abay.sh/cve-2024-0611
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ac6e587c-59b2-4f93-ab88-5e548b52db45?source=cve
Get alerted when CVE-2024-0611 or the next vulnerability affects your stack