What’s Vulnerable › Vulnerabilities
CVE-2024-0614: Events Manager <= 6.4.6.4 - Authenticated(Administator+) Stored Cross-Site Scripting via settings
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Events Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 6.4.6.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- netweblogic Events Manager – Calendar, Bookings, Tickets, and more!: before 6.4.7 — fixed in 6.4.7
How to fix
Upgrade to a fixed version: netweblogic Events Manager – Calendar, Bookings, Tickets, and more! 6.4.7. Check the vendor advisory for mitigations.
References
- https://advisory.abay.sh/cve-2024-0614
- https://plugins.trac.wordpress.org/changeset/3042128/events-manager/trunk/admin/em-options.php?old=2769385&old_path=events-manager/trunk/admin/em-options.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6288fddf-926f-4506-94de-696e0a23766d?source=cve
- https://advisory.abay.sh/cve-2024-0614
- https://plugins.trac.wordpress.org/changeset/3042128/events-manager/trunk/admin/em-options.php?old=2769385&old_path=events-manager/trunk/admin/em-options.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6288fddf-926f-4506-94de-696e0a23766d?source=cve
Get alerted when CVE-2024-0614 or the next vulnerability affects your stack