What’s Vulnerable › Vulnerabilities
CVE-2024-0617: Category Discount Woocommerce <= 4.12 - Missing Authorization via wpcd_save_discount()
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-25 · updated 2026-06-17
- Weakness: CWE-862
Description
The Category Discount Woocommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpcd_save_discount() function in all versions up to, and including, 4.12. This makes it possible for unauthenticated attackers to modify product category discounts that could lead to loss of revenue.
Affected products
- vidishp Simple Discount Rules for Woocommerce: before 4.13 — fixed in 4.13
How to fix
Upgrade to a fixed version: vidishp Simple Discount Rules for Woocommerce 4.13. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woo-product-category-discount/trunk/cd-admin.php#L171
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3026242%40woo-product-category-discount&new=3026242%40woo-product-category-discount&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/996b44bb-d1e0-4f82-b8ee-a98b0ae994f9?source=cve
- https://plugins.trac.wordpress.org/browser/woo-product-category-discount/trunk/cd-admin.php#L171
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3026242%40woo-product-category-discount&new=3026242%40woo-product-category-discount&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/996b44bb-d1e0-4f82-b8ee-a98b0ae994f9?source=cve
Get alerted when CVE-2024-0617 or the next vulnerability affects your stack