What’s Vulnerable › Vulnerabilities
CVE-2024-0640: Stored XSS in chatwoot/chatwoot
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability exists in chatwoot/chatwoot versions 3.0.0 to 3.5.1. This vulnerability allows an admin user to inject malicious JavaScript code via the dashboard app settings, which can then be executed by another admin user when they access the affected dashboard app. The issue is fixed in version 3.5.2.
Affected products
- chatwoot/chatwoot: before 3.5.2 — fixed in 3.5.2
How to fix
Upgrade to a fixed version: chatwoot/chatwoot 3.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/chatwoot/chatwoot/commit/e39c14460b860d5e3d23d989dd6af48404ad1bb4
- https://huntr.com/bounties/08b3bebf-ce3c-4416-b75e-1927ba61de85
Get alerted when CVE-2024-0640 or the next vulnerability affects your stack