What’s Vulnerable › Vulnerabilities
CVE-2024-0677: Pz-LinkCard <= 2.5.1 - Contributor+ SSRF
- Severity: medium (CVSS 5.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-28 · updated 2026-06-17
- Weakness: CWE-918
Description
The Pz-LinkCard WordPress plugin through 2.5.1 does not prevent users from pinging arbitrary hosts via some of its shortcodes, which could allow high privilege users such as contributors to perform SSRF attacks.
Affected products
- Pz-LinkCard: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: Pz-LinkCard 2.5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0f7757c9-69fa-49db-90b0-40f0ff29bee7/
- https://wpscan.com/vulnerability/0f7757c9-69fa-49db-90b0-40f0ff29bee7/
Get alerted when CVE-2024-0677 or the next vulnerability affects your stack