What’s Vulnerable › Vulnerabilities
CVE-2024-0680: WP Private Content Plus <= 3.6 - Protection Mechanism Bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-693
Description
The WP Private Content Plus plugin for WordPress is vulnerable to information disclosure in all versions up to, and including, 3.6. This is due to the plugin not properly restricting access to posts via the REST API when a page has been made private. This makes it possible for unauthenticated attackers to view protected posts.
Affected products
- nimeshrmr WP Private Content Plus: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: nimeshrmr WP Private Content Plus 3.6.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3046309%40wp-private-content-plus&new=3046309%40wp-private-content-plus&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/wp-private-content-plus/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/43d8904f-3bc9-4c67-b44b-8d78762b6b30?source=cve
- https://wordpress.org/plugins/wp-private-content-plus/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/43d8904f-3bc9-4c67-b44b-8d78762b6b30?source=cve
Get alerted when CVE-2024-0680 or the next vulnerability affects your stack