What’s Vulnerable › Vulnerabilities
CVE-2024-0702: Oliver POS – A WooCommerce Point of Sale (POS) <= 2.4.2.1 - Missing Authorization
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-862
Description
The Oliver POS – A WooCommerce Point of Sale (POS) plugin for WordPress is vulnerable to unauthorized access due to missing capability checks on several functions hooked via AJAX in the includes/class-pos-bridge-install.php file in all versions up to, and including, 2.4.2.1 This makes it possible for authenticated attackers, with subscriber-level access and above, to perform several unauthorized actions like deactivating the plugin, disconnecting the subscription, syncing the status and more.
Affected products
- oliverpos Oliver POS – A WooCommerce Point of Sale (POS): before 2.4.2.1 — fixed in 2.4.2.1
How to fix
Upgrade to a fixed version: oliverpos Oliver POS – A WooCommerce Point of Sale (POS) 2.4.2.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/oliver-pos/trunk/includes/class-pos-bridge-install.php#L11
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3038694%40oliver-pos&new=3038694%40oliver-pos&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b5c6f351-477b-4384-9863-fe3b45ddf21d?source=cve
- https://plugins.trac.wordpress.org/browser/oliver-pos/trunk/includes/class-pos-bridge-install.php#L11
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b5c6f351-477b-4384-9863-fe3b45ddf21d?source=cve
Get alerted when CVE-2024-0702 or the next vulnerability affects your stack