What’s Vulnerable › Vulnerabilities
CVE-2024-0745
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-23 · updated 2026-06-17
- Weakness: CWE-787
Description
The WebAudio `OscillatorNode` object was susceptible to a stack buffer overflow. This could have led to a potentially exploitable crash. This vulnerability affects Firefox < 122.
Affected products
- Mozilla Firefox: before 122.0 — fixed in 122.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 122.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1871838
- https://www.mozilla.org/security/advisories/mfsa2024-01/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1871838
- https://www.mozilla.org/security/advisories/mfsa2024-01/
Get alerted when CVE-2024-0745 or the next vulnerability affects your stack