What’s Vulnerable › Vulnerabilities
CVE-2024-0766: Envo's Elementor Templates & Widgets for WooCommerce <= 1.4.4 - Missing Authorization via templates_ajax_request
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-284
Description
The Envo's Elementor Templates & Widgets for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the templates_ajax_request function in all versions up to, and including, 1.4.4. This makes it possible for subscribers and higher to create templates.
Affected products
- envothemes Envo's Templates & Widgets for Elementor and WooCommerce: before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: envothemes Envo's Templates & Widgets for Elementor and WooCommerce 1.4.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/envo-elementor-for-woocommerce/trunk/includes/admin/include/template-library.php
- https://plugins.trac.wordpress.org/changeset/3041303/envo-elementor-for-woocommerce/trunk/includes/admin/include/template-library.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/996c7433-dd82-4216-86b9-005f43c06c3a?source=cve
- https://plugins.trac.wordpress.org/browser/envo-elementor-for-woocommerce/trunk/includes/admin/include/template-library.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/996c7433-dd82-4216-86b9-005f43c06c3a?source=cve
Get alerted when CVE-2024-0766 or the next vulnerability affects your stack