What’s Vulnerable › Vulnerabilities
CVE-2024-0767: Envo's Elementor Templates & Widgets for WooCommerce <= 1.4.4 - Cross-Site Request Forgery via ajax_plugin_activation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-352
Description
The Envo's Elementor Templates & Widgets for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.4.4. This is due to missing or incorrect nonce validation on the ajax_plugin_activation function. This makes it possible for unauthenticated attackers to activate arbitrary installed plugins via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- envothemes Envo's Templates & Widgets for Elementor and WooCommerce: before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: envothemes Envo's Templates & Widgets for Elementor and WooCommerce 1.4.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3041303/envo-elementor-for-woocommerce/trunk/includes/admin/include/template-library.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cca71257-05dc-43d5-8de6-faf0a2feab2e?source=cve
- https://plugins.trac.wordpress.org/browser/envo-elementor-for-woocommerce/trunk/includes/admin/include/template-library.php#L332
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cca71257-05dc-43d5-8de6-faf0a2feab2e?source=cve
Get alerted when CVE-2024-0767 or the next vulnerability affects your stack