What’s Vulnerable › Vulnerabilities
CVE-2024-0820: Jobs for WordPress < 2.7.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Jobs for WordPress plugin before 2.7.4 does not sanitise and escape some parameters, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- BlueGlass Jobs for WordPress: before 2.7.4 — fixed in 2.7.4
How to fix
Upgrade to a fixed version: BlueGlass Jobs for WordPress 2.7.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fc091bbd-7338-4bd4-add5-e46502a9a949/
- https://wpscan.com/vulnerability/fc091bbd-7338-4bd4-add5-e46502a9a949/
Get alerted when CVE-2024-0820 or the next vulnerability affects your stack