What’s Vulnerable › Vulnerabilities
CVE-2024-0825: Vimeography: Vimeo Video Gallery WordPress Plugin <= 2.3.2 - Authenticated (Contributor+) PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-502
Description
The Vimeography: Vimeo Video Gallery WordPress Plugin plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.3.2 via deserialization of untrusted input via the vimeography_duplicate_gallery_serialized in the duplicate_gallery function. This makes it possible for authenticated attackers attackers, with contributor access or higher, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- videogallery Vimeography: Vimeo Video Gallery WordPress Plugin: before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: videogallery Vimeography: Vimeo Video Gallery WordPress Plugin 2.3.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/vimeography/trunk/lib/api/galleries.php#L816
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3049222%40vimeography&new=3049222%40vimeography&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/853516b2-ec50-4937-89d3-d16042a6f71c?source=cve
- https://plugins.trac.wordpress.org/browser/vimeography/trunk/lib/api/galleries.php#L816
- https://www.wordfence.com/threat-intel/vulnerabilities/id/853516b2-ec50-4937-89d3-d16042a6f71c?source=cve
Get alerted when CVE-2024-0825 or the next vulnerability affects your stack