What’s Vulnerable › Vulnerabilities
CVE-2024-0829: Comments Extra Fields For Post,Pages and CPT <= 5.0 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-08-11
- Weakness: CWE-862
Description
The Comments Extra Fields For Post,Pages and CPT plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 5.0. This is due to missing or incorrect capability checks on several ajax actions. This makes it possible for authenticated attackers, with subscriber access or higher, to invoke those actions. As a result, they may modify comment form fields and update plugin settings.
Affected products
- nmedia Comments Extra Fields For Post,Pages and CPT: before 5.1 — fixed in 5.1
How to fix
Upgrade to a fixed version: nmedia Comments Extra Fields For Post,Pages and CPT 5.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-comment-fields/trunk/classes/admin.class.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3040734%40wp-comment-fields%2Ftrunk&old=3039523%40wp-comment-fields%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cc5754c2-a052-41ac-af19-7c4f55860f95?source=cve
- https://plugins.trac.wordpress.org/browser/wp-comment-fields/trunk/classes/admin.class.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3040734%40wp-comment-fields%2Ftrunk&old=3039523%40wp-comment-fields%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cc5754c2-a052-41ac-af19-7c4f55860f95?source=cve
Get alerted when CVE-2024-0829 or the next vulnerability affects your stack