What’s Vulnerable › Vulnerabilities
CVE-2024-0832: Privilege Elevation via Telerik Reporting Installer
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-31 · updated 2026-06-17
- Weakness: CWE-269
Description
In Telerik Reporting versions prior to 2024 R1, a privilege elevation vulnerability has been identified in the applications installer component. In an environment where an existing Telerik Reporting install is present, a lower privileged user has the ability to manipulate the installation package to elevate their privileges on the underlying operating system.
Affected products
- Progress Software Telerik Reporting: before 18.0.24.130 — fixed in 18.0.24.130
How to fix
Upgrade to a fixed version: Progress Software Telerik Reporting 18.0.24.130. Check the vendor advisory for mitigations.
References
- https://docs.telerik.com/reporting/knowledge-base/legacy-installer-vulnerability
- https://www.telerik.com/products/reporting.aspx
- https://docs.telerik.com/reporting/knowledge-base/legacy-installer-vulnerability
- https://www.telerik.com/products/reporting.aspx
Get alerted when CVE-2024-0832 or the next vulnerability affects your stack