What’s Vulnerable › Vulnerabilities
CVE-2024-0839: FeedWordPress <= 2022.0222 - Insecure Direct Object Referece
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-639
Description
The FeedWordPress plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2022.0222 due to missing validation on the user controlled 'guid' key. This makes it possible for unauthenticated attackers to view draft posts that may contain sensitive information.
Affected products
- radgeek FeedWordPress: before 2024.0428 — fixed in 2024.0428
How to fix
Upgrade to a fixed version: radgeek FeedWordPress 2024.0428. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3078610%40feedwordpress%2Ftrunk&old=3048697%40feedwordpress%2Ftrunk&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/feedwordpress/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1ead46fd-5744-4fbb-9efd-980f9216abbc?source=cve
- https://wordpress.org/plugins/feedwordpress/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1ead46fd-5744-4fbb-9efd-980f9216abbc?source=cve
Get alerted when CVE-2024-0839 or the next vulnerability affects your stack