What’s Vulnerable › Vulnerabilities
CVE-2024-0840: Grandstream UCM Series IP PBX HTTP Parameter Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-29 · updated 2026-06-17
- Weakness: CWE-141
Description
The Grandstream UCM Series IP PBX before firmware version 1.0.20.52 is affected by a parameter injection vulnerability in the HTTP interface. A remote and authenticated attacker can execute arbitrary code by sending a crafted HTTP request. Authentication may be possible using a default user and password. Affected models are the UCM6202, UCM6204, UCM6208, and UCM6510.
Affected products
- Grandstream Ucm6202 Firmware: before 1.0.20.52 — fixed in 1.0.20.52
- Grandstream Ucm6204 Firmware: before 1.0.20.52 — fixed in 1.0.20.52
- Grandstream Ucm6208 Firmware: before 1.0.20.52 — fixed in 1.0.20.52
- Grandstream Ucm6510 Firmware: before 1.0.20.52 — fixed in 1.0.20.52
How to fix
Upgrade to a fixed version: Grandstream Ucm6202 Firmware 1.0.20.52; Grandstream Ucm6204 Firmware 1.0.20.52; Grandstream Ucm6208 Firmware 1.0.20.52; Grandstream Ucm6510 Firmware 1.0.20.52. Check the vendor advisory for mitigations.
References
- https://vulncheck.com/advisories/grand-stream-param-injection
- https://vulncheck.com/advisories/grand-stream-param-injection
Get alerted when CVE-2024-0840 or the next vulnerability affects your stack