What’s Vulnerable › Vulnerabilities
CVE-2024-0864: RCE in Laragon
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-434
Description
Enabling Simple Ajax Uploader plugin included in Laragon open-source software allows for a remote code execution (RCE) attack via an improper input validation in a file_upload.php file which serves as an example. By default, Laragon is not vulnerable until a user decides to use the aforementioned plugin.
Affected products
- Leo Khoa Laragon: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: Leo Khoa Laragon 7.0.0. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2024/02/CVE-2024-0864
- https://cert.pl/posts/2024/02/CVE-2024-0864
- https://laragon.org/
- https://cert.pl/en/posts/2024/02/CVE-2024-0864
- https://cert.pl/posts/2024/02/CVE-2024-0864
- https://laragon.org/
Get alerted when CVE-2024-0864 or the next vulnerability affects your stack