What’s Vulnerable › Vulnerabilities
CVE-2024-0873: Watu Quiz <= 3.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Watu Quiz plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'watu-basic-chart' shortcode in all versions up to, and including, 3.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Bob Watu Quiz: before 3.4.1.1 — fixed in 3.4.1.1
How to fix
Upgrade to a fixed version: Bob Watu Quiz 3.4.1.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3036986/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c31732fa-eb35-4932-bee6-08955a14b010?source=cve
- https://plugins.trac.wordpress.org/changeset/3036986/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c31732fa-eb35-4932-bee6-08955a14b010?source=cve
Get alerted when CVE-2024-0873 or the next vulnerability affects your stack