What’s Vulnerable › Vulnerabilities
CVE-2024-0905: Fancy Product Designer < 6.1.8 - Reflected Cross Site Scripting
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Fancy Product Designer WordPress plugin before 6.1.8 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against unauthenticated and admin-level users
Affected products
- radykal Fancy Product Designer: before 6.1.8 — fixed in 6.1.8
How to fix
Upgrade to a fixed version: radykal Fancy Product Designer 6.1.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3b9eba0d-29aa-47e4-b17f-4cf4bbf8b690/
- https://wpscan.com/vulnerability/3b9eba0d-29aa-47e4-b17f-4cf4bbf8b690/
Get alerted when CVE-2024-0905 or the next vulnerability affects your stack