What’s Vulnerable › Vulnerabilities
CVE-2024-0910: Restrict for Elementor <= 1.0.7 - Protection Mechanism Bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-200
Description
The Restrict for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.0.7 due to improper restrictions on hidden data that make it accessible through the REST API. This makes it possible for unauthenticated attackers to extract potentially sensitive data from post content.
Affected products
- Restrict for Elementor: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: Restrict for Elementor 1.0.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3104418%40restrict-for-elementor&new=3104418%40restrict-for-elementor
- https://wordpress.org/plugins/restrict-for-elementor/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/14993c04-7fe3-4c42-a605-2e431df14d79?source=cve
- https://wordpress.org/plugins/restrict-for-elementor/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/14993c04-7fe3-4c42-a605-2e431df14d79?source=cve
Get alerted when CVE-2024-0910 or the next vulnerability affects your stack