What’s Vulnerable › Vulnerabilities
CVE-2024-0952: WP ERP <= 1.12.9 - Authenticated (Accounting Manager+) SQL Injection via id
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting plugin for WordPress is vulnerable to time-based SQL Injection via the id parameter in all versions up to, and including, 1.12.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with accounting manager or admin privileges or higher, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- weDevs WP ERP: before 1.13.0 — fixed in 1.13.0
How to fix
Upgrade to a fixed version: weDevs WP ERP 1.13.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3060269/erp/tags/1.13.0/modules/accounting/includes/functions/people.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f3ba06f9-de51-49ea-87c1-4583e939314b?source=cve
- https://plugins.trac.wordpress.org/changeset/3060269/erp/tags/1.13.0/modules/accounting/includes/functions/people.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f3ba06f9-de51-49ea-87c1-4583e939314b?source=cve
Get alerted when CVE-2024-0952 or the next vulnerability affects your stack