What’s Vulnerable › Vulnerabilities
CVE-2024-0974: Social Media Widget < 4.0.9 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Media Widget WordPress plugin before 4.0.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Social Media Widget: before 4.0.9 — fixed in 4.0.9
How to fix
Upgrade to a fixed version: Social Media Widget 4.0.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7f8e5e63-a928-443e-9771-8b3f51f5eb9e/
- https://wpscan.com/vulnerability/7f8e5e63-a928-443e-9771-8b3f51f5eb9e/
Get alerted when CVE-2024-0974 or the next vulnerability affects your stack