What’s Vulnerable › Vulnerabilities
CVE-2024-0978: My Private Site <= 3.0.14 - Improper Access Control to Sensitive Information Exposure via REST API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-284
Description
The My Private Site plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.14 via the REST API. This makes it possible for unauthenticated attackers to bypass the plugin's site privacy feature and view restricted page and post content.
Affected products
- My Private Site: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: My Private Site 3.1.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3036015/jonradio-private-site
- https://www.wordfence.com/threat-intel/vulnerabilities/id/970bc71c-7d0a-4761-874a-379cda71418e?source=cve
- https://plugins.trac.wordpress.org/changeset/3036015/jonradio-private-site
- https://www.wordfence.com/threat-intel/vulnerabilities/id/970bc71c-7d0a-4761-874a-379cda71418e?source=cve
Get alerted when CVE-2024-0978 or the next vulnerability affects your stack