What’s Vulnerable › Vulnerabilities
CVE-2024-10000: Masteriyo LMS – eLearning and Online Course Builder for WordPress <= 1.13.3 - Authenticated (Student+) Stored Cross-Site Scripting via Ask a Question Functionality
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Masteriyo LMS – eLearning and Online Course Builder for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the question's content parameter in all versions up to, and including, 1.13.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with student-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Masteriyo - LMS: before 1.13.4 — fixed in 1.13.4
How to fix
Upgrade to a fixed version: Masteriyo - LMS 1.13.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/learning-management-system/tags/1.13.3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/575f103e-cfc7-4efd-a592-658a3e919671?source=cve
Get alerted when CVE-2024-10000 or the next vulnerability affects your stack