What’s Vulnerable › Vulnerabilities
CVE-2024-10001: Code Injection Vulnerability in GitHub Enterprise Server Allows Arbitrary Code Execution via Message Handling
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-94
Description
A Code Injection vulnerability was identified in GitHub Enterprise Server that allowed attackers to inject malicious code into the query selector via the identity property in the message handling function. This enabled the exfiltration of sensitive data by manipulating the DOM, including authentication tokens. To execute the attack, the victim must be logged into GitHub and interact with the attacker controlled malicious webpage containing the hidden iframe. This vulnerability occurs due to an improper sequence of validation, where the origin check occurs after accepting the user-controlled identity property. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.11.16, 3.12.10, 3.13.5, 3.14.2, and 3.15.0. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: before 3.11.6; from 3.12.0 before 3.12.10; from 3.13.0 before 3.13.5; from 3.14.0 before 3.14.2 — fixed in 3.11.6, 3.12.10, 3.13.5, 3.14.2
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.11.6, 3.12.10, 3.13.5, 3.14.2. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.17
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.11
- https://docs.github.com/en/enterprise-server@3.13/admin/release-notes#3.13.6
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.3
- https://docs.github.com/en/enterprise-server@3.15/admin/release-notes#3.15.0
Get alerted when CVE-2024-10001 or the next vulnerability affects your stack